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Features
Provide Wi-Fi hotspot support (wireless billing)
Utilize pre-paid tickets (time codes)
Setup any complicated pricing
Setup point-of-sale
Use inventory system
C alculate Internet traffic and browse URL log
Limit Internet bandwidth
Use shits to control your operators
Analyze your business data
Backup your data and settings

Provide Wi-Fi hotspot support (wireless billing)
C harge the customers of your cafe, club, shop, hotel, etc. when they connect their laptops, PDAs or
any other mobile devices to your access point (Wi-Fi hotspot) and use the Internet to surf the web,
read emails or chat via an instant messenger. Use white list feature to specify Wi-Fi billing exceptions.
Read more

Utilize pre-paid tickets (time codes)
C reate, print, sell, delete or recover pre-paid tickets. Distribute tickets among your employees
(agents). Keep track of a ticket status. Delete all unused tickets. Use a ticket to top-up a customer
session. C reate promotional tickets.
Read more

Setup any complicated pricing
C onfigure pricing per minute, hour, an item or setup a table of fixed sums that are added to a bill;
round amount of a service; setup taxing (included in or excluded of the price). C reate a number of
time zones with distinct pricing for each one. Setup amount-dependent pricing (e.g. 1 hour = $5, 2
hours = $7, etc.). C reate service packages for each type of customers you have (standard customers,
students, employees, VIP, etc.).
Read more

Setup point-of-sale
Sell products in your shop, club, cafe, etc. Make a walk-in (guest) and member sales, select multiple
items into a bill, add/remove items from a bill. Print a receipt on a receipt printer or any other printer.

Make your unique receipt design.
Read more

Use inventory system
C ontrol available amount of your items in the stock. Use your barcode scanner when you sell the
items.
Read more

C alculate Internet traffic and browse URL log
C uteHotspot calculates amount of Intenet traffic for a user's session. URL log: keep track of the
Internet websites and pages which a customer opens on his terminal.
Read more

Limit Internet bandwidth
You can specify some Internet bandwidth usage limit for every customer terminal. Depending on a
pricing package, a bandwidth limit can be 64, 96, 128, etc. kbps or unlimited.
Read more

Use shifts to control your operators
C ontrol your operators and cash flow using the shift management feature.
Every operator computer is considered as a cash desk so that each shift is linked to the corresponding
cash desk. When an operator starts working with the program collecting any payment,
starting/stopping customer sessions, etc., he has to start a shift. When he finishes working with the
software, he stops his shift.
Read more

Analyze your business data
Use C uteHotspot Reports to analyze your business data: the list of customers detailed by sessions and
services provided; the list of services detailed by customers; the list of sessions; the list of system
events (changes in the state of computers, the start/stop of the server, etc.).
Read more

Backup your data and settings
Backup and restore C uteHotspot database. C onfigure a backup schedule to backup your data and
settings automatically. C lean up the database.
Read more

System Requirements
Operating system: Microsoft Windows NT/2000/XP/Vista (Windows 95/98/ME is not longer
supported)
Hardware requirements:



Processor: Intel Pentium II or higher (P4 is recommended)



Memory: minimum 512 MB of RAM (1024 MB is recommended)



Disk usage: 20 MB of hard disk space + about 300 MB space for database is recommended



Video: VGA or higher resolution monitor



Mouse is required

It is recommended to install Microsoft Data Access C omponents (MDAC ) version 2.7 or later versions.
MDAC is available for downloading from Microsoft web site:
Download MDAC 2.8

History
Version 4.6 (Apr 2011)
Key new features:



Export to C SV



C ustom ticket layout



C ut tickets

Minor improvements:



New operator access options: top-up customer accounts, start/extend sessions



No need to restart server any more when new tickets created



"Run as Administrator" not required to register the software



Sell items: fractional quantities



Daily report. An operator only sees his/her sales



Options value field size increased



Program error reports by email

Bugs fixed:



"List index..." error when adding inventories

Version 2.3 (Jul 2010)
Key new features:



Scan customer documents



Session rounding



Ticket printer

Minor improvements:



Tickets are available on the expiry date and disabled the next day



Ticket expiry date "today": sale/login date + 0 days



Auto-close pre-paid sessions stopped from the server side



Security options: change time/money and paid amounts



Log outs list performance improvement



Proxy 8080 and 3128 ports are supported

Bugs fixed:



Network driver can't be installed on Windows Vista/7/2008 64-bit versions



Traffic counter resets when the info page refreshes



Ticket login mask isn't applied to "login = ID" tickets



Incorrect 1-minute rounding



Incorrect 1-minute rounding



Program registration on Windows 7 and Vista



Duplicated Wi-Fi sessions when a terminal IP is changed



Printing tickets on some receipt printer models ("division by zero" error)

Version 2.2 (Jun 2009)
Key new features:



Bandwidth management



Wi-Fi white list



Top-up and ticket receipts

Minor improvements:



Options. C hange currency sign



Logouts list (instead of open sessions list)



Taxes. All prices and amounts include taxes



Receipt. Sale date section



Performance improvements



Sales. Allow negative quantity



Ticket top-up. Display customer as transaction owner



Tickets recover: administrator only



Wi-Fi. Display full redirect (domain + document + params) on the status page



Sale window. Display prices + tax



Sales report. Display shift operator



Rename main menu > View > Shift report -> Daily report



Discount column in Web Reports, Sales report and Daily report



Hide private pricing packages on the customer window from non-Admin users



Display pricing package ID (main menu > Setup > Pricing)



Auto-close sessions option: any pre-paid by default

Bugs fixed:



Add time/money doesn't work well with decreasing pricing table



Server doesn't delete a wi-fi terminal when a session ends



Shift end_fact becomes NULL. C auses startup exception



URL log. URLs with more than 1024 characters corrupt the database



Setup fails on 64-bit Windows versions



Setup doesn't add firewalls exceptions on Vista



Vista. Restart server doesn't work

Version 2.1 (Oct 2008)


Shift management



Wi-Fi session timeout



C reate promotional tickets



Get original website redirect link on the Wi-Fi login page



Sales report



View customer sessions from the customer window



C lean-up. Delete sales data



Select data folder when you install C uteHotspot

Technical support
We provide full technical support on our product. If you have any questions, suggestions or comments
on our software, please contact us by e-mail:
support@cutehotspot.com
For the latest news and downloads related to our products please visit our website:
http://www.cutehotspot.com
You could post your feedbacks to our forum as well:
http://www.cutehotspot.com/forum/

Licensing
You can use the demo version of C uteHotspot for evaluation purposes only. C uteHotspot demo provides
you with 2 simultaneous wireless connections maximum.
To purchase a registered version please visit our order page

Quick Start
This section helps you start working in C uteHotspot in a few minutes.

1. Configure your network

(Step-by-step simple Wi-Fi billing setup guide)
Install C uteHotspot on your Internet gateway computer. The gateway handles all network connections
from your customer terminals.
In order to setup such a gateway, you should install two network cards on your server computer, the
first card connected to your ISP (ADSL, cable, etc.), the second one connected to your customer
terminals network and setup Windows Internet C onnection Sharing between them.
Read more about network setup

2. Create pre-paid tickets
C reate pre-paid tickets (time codes) which you sell to your customers. A ticket contains its current
balance, login and password.
Open the tickets screen (main menu > Setup > Tickets), press the "New" button, specify tickets
minutes, price and the number of tickets to create:
Read more about tickets

3. Restart server computer
Restart your server computer to apply the changes.

4. Sell tickets
Once a customer comes to your shop, hotel, club, etc. and want to connect to your Wi-Fi billing system,
he has to purchase a ticket which he then use to login.
Select a ticket in the list (or enter the ticket ID) and press the "Sell" button.
You can print a number of tickets in bulk from the ticket screen (main menu > Setup > Tickets), put
them in your cash drawer and enter the ticket ID on the main screen when you sell it to a customer.
Read more about tickets

5. Log in
A customer opens a website from his wireless terminal and C uteHotspot redirects him to the login page
if his billing session hasn't been started yet. The customer use a purchased ticket to log in.

6. Log off
A customer presses the "Logoff" button on his session info page to stop the session.

Software Setup

(Step-by-step simple Wi-Fi billing setup guide)

Introduction
Wireless billing allows you to charge the customers of your cafe, club, shop, hotel, etc. when they
connect their laptops, PDAs or any other mobile devices to your access point (Wi-Fi hotspot) and use the
Internet to surf the web, read emails or chat via an instant messenger.
When a customer opens any web site, C uteHotspot detects the connection and redirects it to the
C uteHotspot Wi-Fi billing login page. The customer uses his or her login information (printed e.g. on a
ticket you sell, on a receipt of your cafe, etc.) to start a session. When the balance is over, C uteHotspot
blocks any further connections from the corresponding customer terminal.
In order to provide the wireless billing you have to install C uteHotspot Server on your Internet gateway
computer (Windows OS is only supported). The gateway handles all network connections from your
customer terminals.

We recommend using the following approach... There are 2 network cards (NIC s) in your Internet
gateway computer - NIC 1 and NIC 2. NIC 1 is connected to the Internet (WAN) via xDSL/ADSL, C able,
etc. NIC 2 is connected to your LAN: Wi-Fi access point, hub, switch, etc.
Use Windows Internet C onnection Sharing feature in order to make a bridge between NIC 1 and NIC 2.

Setup
Setup Internet C onnection Sharing between the network cards on your Internet gateway (server)
computer. Your WAN-connected network card (NIC 1) has IP address usually provided by your Internet
Service Provider. Your LAN-connected network card (NIC 2) obtains some internal IP address, most
often 192.168.0.1.

Read more about how to setup Internet C onnection Sharing
Your Wi-Fi access point uses DHC P to assign a dynamic IP to a customer's wireless laptop when it's
connected. Your access point gateway IP = your NIC 2 IP address (192.168.0.1).
Please make sure that you have your wi-fi router NAT feature disabled. Otherwise all your wi-fi
terminals IP addresses are translated into the single router IP address on the server side.
If you use a router in your LAN, its gateway has to be your NIC 2 IP address as well (192.168.0.1).

You don't have to manually add your wireless terminals on the CuteHotspot server side.
CuteHotspot automatically adds a new terminal when a customer successfully logs in.
Use C uteHotspot Wi-Fi options screen to select your NIC 2 adapter and enable the Wi-Fi billing feature
(main menu > Tools > Wi-Fi...):

Run!
When a customer comes to your cafe, shop, hotel, etc. and connects to your Wi-Fi access point, it
assigns a new dynamic IP address to the customer's wireless laptop.
Then the customer tries to browse the web and since he or she hasn't been logged in yet, C uteHotspot
Server redirects him/her to the login page.
The customer logs in using login/password printed on a purchased ticket.
On the C uteHotspot server side you see that a new Wi-Fi terminal is added.
In order to view the session info such as the balance or time left in a web browser, the customer types
your gateway computer name in the browser address bar (e.g. "gate" on the screenshot below).
The customer can log off from the session info page. You can also stop his session from the server side.
When the customer balance is over, C uteHotspot automatically stops the customer session and blocks
any further connection from his wireless terminal.

Customize
If you have some HTML experience, you can customize your Wi-Fi login and session info pages. Edit the
login.html and info.html files which are located in the C uteHotspot\web folder.

Options
Timeout - stop a Wi-Fi session automatically when it's inactive for a few minutes or a customer leaves
your shop not logging out.

Known issues. Skype
Skype installed on your server may conflict with C uteHotspot. Open Skype main menu > Tools >
Options > Advanced > C onnections, disable Use port 80... option, and restart your server computer:

Login page: your cafe logo

Replace the logo.gif file in the C uteHotspot/web installation folder with your cafe logo.

Administrator
C uteHotspot main screen displays:



main menu and toolbar



customer list (top left)



system log (bottom left)



terminal icons/list (center)



terminal toolbar with the "arrange terminals" and "list" buttons, start/stop/timer/refresh buttons



session summary for a selected terminal (top right)



log-outs (bottom right)

The "List" button switches main screen from terminal icons to the list:

Quick Setup
Open C uteHotspot main menu > Setup > Quick setup

1. Select language
2. Set currency symbol
3. Set guest rates
Select payment mode (pre-paid or post-paid) and specify rates for your quest customers.

4. Create tickets
Read more on how to create and use pre-paid tickets

5. Change administrator password
6. Import customers
If you use to have any billing system before, you can import the customer list from MS-Excel file in the
appropriate format:

Pricing
We recommend using the pre-paid tickets and the ticket setup wizard which helps you setup your pricing
as well.
Read more about tickets
Read the information below if you need some complicated pricing setup.

Pricing packages
You can setup individual time/traffic pricing for each type of your customers (general, students, VIPs,
etc.). C reate as many pricing packages as many types of customers you have.

Pricing properties
Simple mode:

Extended mode:



name on receipt, if different from the base name



taxing value and type: included in or excluded from the price



time zones with individual pricing for each zone



minimal charge



test your pricing

Customer default pricing
You can assign a pricing package to any customer:

Customers
There are three types of customer accounts in C uteHotspot:
1. Guest. This is a customer account which you can use for any customer.
2. Member. Any customer which has balance in your cyber cafe. You create member accounts manually.
3. Ticket (time code). Pre-generated account which can be sold to any customer. You generate a
number of tickets for further use.

Customer account
Property

Meaning

Enabled

Whether this account can be used to login

Balance

Amount of money left on the account

C redit

Maximum amount (negative) which a customer
owes your club. When a customer balance
exceeds the credit amount, neither a session can
be started nor an item can be sold to the
customer.

Pricing

Pricing package.
Read more about pricing

Payment

Pre-paid or post-paid method
Read more

Time left

Approximate amount of time left based on the
customer balance and the selected rate

C olour box

Highlight a customer account in the customer or
session list

Top-up (put some money) account
Select a customer in the list and press the "Top-up" button:

Enter the amount of money to put onto the account and the amount of cash received (if differs), select
the method of payment (cash, credit card):

Virtual cash
You can use the "virtual cash" concept to top-up an account without putting real money onto it. Virtual
cash doesn't impact your financial reports.

Security
Only a supervisor account (Adm) or a "User access administrator" can change user security
settings.
Option

Meaning

Login

C an login into C uteHotspot Administrator. Such
users are highlighted by red in the customer list

Reports

C an login into C uteHotspot Reports

User access administrator

C an change user security settings

Max number of occupied terminals

How many terminals can be occupied using this
account simultaneously

Inventory administrator

C onfigure inventory, add and remove items

Refunds

Make refunds

The other options are:



Top-up customer accounts



Start sessions



Extend sessions

Adm account rule. Administrator account (Adm) security settings can be changed by Adm user only.
Administrator can change the security settings of any user account.

Login name rule. An operator can set an account login name when he creates a new user account. An
operator can't change his own login name. Administrator and user security administrators can change
any login name.
Password rule. An operator can set a password when he creates a new user account. Any user can
change his password. Administrator and user security administrators can change any password.
Enable/disable account rule. Only administrator and user security administrators can enable/disable
a user account.

Scan customer documents
Scan customer documents such as a photo, passport, driving license, etc. C lick on the customer icon to
scan a photo or use the Documents tab to scan any other documents.

Tickets (Time Codes)
A ticket is a pre-generated customer account that can be printed, distributed, sold to a customer and
then used by a customer to log in.
Any ticket has one of the following states at any moment: created, printed, sold, in use, used up,
deleted. A customer can log in using a ticket which state is "sold" or "in use" only.
Use the ticket desktop for main ticket management operations (main menu > Setup > Tickets).

Ticket ownership
Any ticket belongs to an employee, who only can sell it. You can generate tickets for each of your
employee to let them distribute/sell tickets. Use "guest" as a ticket owner, to share the created tickets
among all employees.

Create tickets
Press the "New" button to display "C reate tickets" dialog.
1. Enter the tickets minutes.

2. Enter the bandwidth limit in Mbytes.
3. Enter the tickets price.
4. Enter the number of tickets to create.
5. Set the expiry date (optional). You can select a fixed date, or a sale date + X days, or a first login
date + X days.
6. Set time of day limit. If time of day is specified, customers can't log at the other time using these
tickets.
7. C hoose a login generation method: login = ticket id or login = random.
8. Select an onwer from the list of cyber cafe employees.

Print tickets
Select a number or tickets in the list and press the "Print" button.
Specify whether you want to print a number of tickets on the same page (e.g. A4) or cut every ticket (1
page = 1 ticket). The latter approach is useful when you print tickets on the receipt printer.

You can put the printed tickets in your cash drawer and sell them to your customers.
You can also export the ticket list to Microsoft Excel or C SV for further external professional
design/printing.

Sell tickets online
Online sale means that you register the sale at the same time as you give a ticket to a customer.
Select a ticket in the list on the main C uteHotspot screen and press the "Sell" button. If "Print" is
checked, the ticket is printed when the sale is made.
If you keep your tickets pre-printed (e.g. in a cash drawer), you can simply enter the corresponding
ticket number in the edit box and press the "Sell" button.

Sell tickets offline
Offline sale implies that you provide a customer with a ticket and register the sale later. For example,
your agents may distribute printed tickets during a day and register all the sales in the evening.
Open the ticket desktop, select the sold tickets in the list and press the "Sell" button.

Use tickets to log in
Use a ticket login/password to start a session from the client side.

Delete and recover tickets
Select tickets you want to delete and press the "Delete" button. If you need to recover a previously
deleted ticket, select it and press the "Recover" button.
Use the "Delete all used up tickets" button to delete all tickets which have been completely used.

Promotional tickets
Use promo tickets to provide limited access for free in order to promote your shop, cafe, etc. When you
sell a promo ticket, you don't actually collect any cash and the corresponding amount is only added to
the promo totals (not cash totals) in the reports.

Custom ticket layout
C ustomize your ticket print layout, add/remove captions, add your cafe logo, etc. Edit tickets.layout
file in the C uteHotspot folder. Preview ticket layouts.

Pre-Paid and Post-Paid Sessions
Pre-paid session has a time limit, based on a customer balance value and the current rate.
C uteHotspot automatically stops a pre-paid session when the available time is over.
Post-paid session doesn't have any time limit. A customer is charged after he ends his session.

Customer starts session from terminal
When a customer opens a website from his terminal, he is automatically redirected to the C uteHotspot
login page.
Use a customer or ticket login/password to login. Only member/ticket sessions with positive balance can
be started this way.

Monitor sessions
Press the "List" button to switch between terminal icons and the session list:

Extend session (add time/money)
Press the "Add time/money" button to extend a session:

1) Pre-paid. Add time and collect corresponding amount of cash:

2) Post-paid. Set/extend time limit. No cash is collected:

Sell item (drink, snack, etc.)
Use the "Sell" terminal popup menu to add any service/product to a session:

Customer stops session
Use the "Log off" button in a web browser to stop your session.

Operator stops session
Select terminal icon or session in the list and press the "Stop" button:

Close session
Open sessions are displayed in the session list. Stopped sessions, which don't occupy the terminals, are
highlighted in grey:

Double-click on a session, collect required cash (or accept a credit card), give change (or put it on the
customer balance) and press the "Paid" button.

A session can be closed automatically if there is enough money on the customer balance. Use the "C lose
sessions" option to enable this feature.

Browse sessions
(main menu > View > Sessions)
The session window displays today/yesterday/this week/etc. customer sessions. Open sessions are
marked with bold navy font.

You can use the session window to print a receipt after a session is closed and disappeares from the
active sessions list on the main screen.

Refunds
Use refunds when your customer returns you some purchased items or you have to rollback an entire
customer session.
Refund feature is available on the sessions window You can only refund closed sessions. When a refund
session is created, use the Delete button to leave the refund items only. Refund sessions are
highlighted with red color in the list.

Shifts
C ontrol your operators and cash flow using the shift management feature.
Every operator computer is considered as a cash desk so that each shift is linked to the corresponding
cash desk. When an operator starts working with the program collecting any payment, starting/stopping
customer sessions, etc., he has to start a shift. When he finishes working with the software, he stops his
shift.
When an operator starts a shift, he types in the program the cash amount he has in the cash desk for
the moment. When he stops the shift, he types the final cash amount for the time.
Any differences between actual and calculated amount are highlighted with red in the shift report. Use
View > Shifts report to browse the shifts.
You can start a shift manually (main menu Setup > Start / Stop shift) or automatically. Enable the
shift control feature (main menu > Options > Shift control) so that an operator can't collect any
payment unless his shift is started.

Point of Sale, Cash Drawer
You can sell drinks, snacks and other items to your customers.

Walk-in sale
Use a walk-in sale for guest customers who don't use any terminals. C lick on the "Walk-in sale" button
in the toolbar:

Select an item, enter quantity and press the "Add" button to add the item to the bill. Double-click on an
item to add it with quantity = 1. Double-click on an item in the bill or press the "Remove" button to
remove the item from the bill.
You can use the inventory system to control item Available amount or use your barcode scanner to
sell the items.

C ollect cash, give change and print a receipt if needed. Press the "Paid" button to close the sale.

Member sale
Member sale is like a walk-in sale, but is made for a particular member.
Select a customer in the list and press the "Sell" button:

If the member account is pre-paid and there is not enough money left on the balance, you will not be
able to make the sale.

Cash drawer
Use C uteHotspot main menu > Tools > POS. C ash drawer to connect program to your cash drawer.
C ash drawer opens when you change a customer balance or start/extend/stop customer sessions.

Inventory
The inventory system helps you to...



C ontrol available items in the stock



Use your barcode scanner to sell the items

Use main menu > Setup > Inventory to open the Inventory management screen:

Create items
C lick on the New button and select the new inventory items from the list of services:

+ Items (Increase Amount)
Increase amount of a particular item in the stock.

Enter the item amount manually or use your barcode scanner for each item:

- Items (Decrease Amount)
Decrease amounts of a few items in the stock.
Select an item and enter the amount manually or use a barcode scanner:

Daily Report
You can analyze your business daily activity and financial information using a brief daily report.
It displays the top-ups, sales made, services provided, detailed log of actions and total cash received for
selected period (today, yesterday, this week, last week, etc.).
Also, you can export the data to MS-Excel or C SV for further analyzing.

Daily report for operator
When an operator runs the daily report, he/she only gets his/her sales and totals.

Sales Report
Sales report (main menu > View > Sales) displays detailed sales records and allows you to filter the list
by customer, service, terminal and operator values.

Traffic Calculation and URL Log
You can calculate and charge a customer session Internet traffic and monitor terminals' URLs. Use
C uteHotspot Internet settings screen to turn on the traffic calculation or URL log features (main menu >
Tools > Internet...):

URL Log
Keep track of the Internet websites and pages which a customer opens on his or her terminal. Use the
terminal popup menu to browse the list of URLs for current session. Use main menu (View -> URL log) to
display the total log.
URL log is data is stored in a detached database (C uteHotspotTraffic.mdb)

Bandwidth Management
You can specify some Internet bandwidth usage limit for every customer terminal. Depending on a
pricing package, a bandwidth limit can be 64, 96, 128, etc. kbps or unlimited.
Bandwidth limit > Download bandwidth + Upload bandwidth

Setup
1. Open your pricing settings: main menu > Setup > Pricing and set bandwidth limits for your pricing
packages.
2. Activate the bandwidth management system: main menu > Tools > Internet... > Bandwidth
management

White List
Specify wireless billing exceptions: website names or terminal IP/MAC addresses. For example, you can
add your employees' laptops addresses here so that they have free access to the Internet.
It makes sense to specify your network printers IP addresses as well so that wireless billing doesn't stop
printing.

Point-of-Sale. Receipt
Print a receipt when you close a session or sale, top-up a customer account, sell a ticket or extend a
session.
C uteHotspot receipt consists of a few sections which can be some text, a picture (e.g. your club logo), a
service list, tax, sum total, etc.
You can add, delete or modify any section, move the section up or down, change the font and
alignment, select a picture on your local drive to put on the receipt, underline a section, etc.
Select a default printer for your receipts, setup a receipt position on the paper (left, top), receipt width,
section height and margins in millimeters, specify whether the receipt border is printed.
You can also modify the pre-defined labels such as "Total", "Tax", "Amount", etc., translating them into
your own language (the "Labels" button), and print a test receipt.

Options
Option

Meaning

General
C lub name

Your cafe/club/hote/etc. name

Language

Interface language

C lose sessions after log off

Automatically close a ticket- or any pre-paid sessions: update
the customer balance and delete the session from the active
sessions list

Disable multiple login

Don't allow simultaneous logins using a single account

Design
Display log

Display the system log pane

Display session

Display the brief session info pane

Display tickets

Display the sale ticket pane

Refresh session every X min

How often the sessions pane is refreshed

Don't refresh when a dialog is being
displayed

Prevents the session pane from being refreshed when a dialog
window (start session, add time/money, etc.) is being displayed

Ping terminals each X sec

How often C uteHotspot pings your terminals and displays a ping
status. We recommend keeping this value about 60 seconds or
higher in order to avoid system slowdown

Buttons
Time/money warn when left

Mimimal amount of time/money left when warnings (colours,
dialogs, sounds, etc.) are displayed

Time/money button 1, button 2, etc.

Amount of time/money that is added to a session when you
press the corresponding button on the "Add time/money" dialog

Show time left warnings on the
server side

Display warnings on the server side

Tickets
Ticket name by default

A name which is assigned to tickets when you create them

Login mask

Add preffix/postfix to a ticket login. When not empty, must
contain %s (e.g. 200801%s). This option is only applied when
you create tickets with login = random option selected.

Ticket terminal count limit by default

Default "Maximum number of occupied terminals" when you
create tickets

Design

Ticket layout on a printed page

Password

Specify a password length, choose whether a password contains
letters or numbers or both, select the upper or lower case and
view an example

Keyboard
Specify the commands to run when you press F2..F9 keys

Reports
C uteHotspot Reports provides 4 reports: customers, services, sessions and events. Each report is timedependent, so you have to enter a start and stop dates (or check the "All time"). Press the "Refresh"
button to run a report.
You can export any data table to Microsoft Excel for further analysis. by click on any data grid and
pressing C trl-E hotkey.

Customers


C ustomers (the main list).



Balance operations (dependent).



Services provided (dependent).



Sessions and jobs (dependent).

Services
Services (main) and customers (dependent).

Sessions
Sessions (main) and jobs (dependent).

Events

System events:



Server state is changed.



Terminal state is changed.

Database Cleanup
Use the database cleanup to delete unused customers, tickets or URL log records.
Delete inactive customers doesn't delete system customers such as annonymous or administrator. It
doesn't delete your operators either.
Clear all sales data irrevocably deletes unused customers, sales, customer sessions, top-ups and
shifts. Use this option in order to optimize your database.
This feature is only available for an administrative user.

Database Workshop
Use Database Workshop to update the C uteHotspot database or make system backup/restore.
Backups are stored in the backup folder of C uteHotspot data directory.

Backup schedule
Select the days of week and set the time when you want C uteHotspot to make a backup of your
database and settings automatically.

How to...
General
How to contact C uteHotspot team
How to purchase a license

Installation
How to setup C uteHotspot

Pricing
How to setup distinct pricing for each group of customers
How to setup a particular pricing
How to get pricing setup examples
How to set a default pricing for a customer

Customers
How to configure a customer account
How to top-up a customer balance
How to promote an account
How to configure user access

Tickets
How to utilize pre-paid tickets (time codes)
How to distribute tickets among your agents/employees
How to create tickets
How to print tickets
How to sell tickets online
How to sell tickets offline
How to log in using a ticket
How to delete and recover tickets

Sessions
How to use pre-paid and post-paid sessions
How to start a session from a terminal
How to monitor customer sessions
How to sell a product (drink, snack, etc.) during a session
How to stop a session from a terminal
How to stop a session from the server
How to close a session
How to make a refund

Internet
How to calculate session Internet traffic/bandwidth

How to limit your terminals Internet bandwidth
How to add wi-fi billing exceptions so that some websites or terminals aren't blocked (white list)

Point of sale
How to make a walk-in (guest customer) sale
How to make a member sale
How to customize a receipt
How to control item available amount in the stock
How to use a barcode scanner to sale items

Backup
How to backup/restore C uteHotspot database and system files
How to configure the backup schedule

Others
How to briefly view your cafe daily activity and financial data
How to analyze your business data
How to clean up the database
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Instant Messenger (C hat)
Organize a chat between operator and a customer on any terminal.
When a new message appears while the chat window is closed, the unread messages indicator is displayed in the toolbar.
Press Enter button to send a message. Press Esc button to close the chat window.

Send text message to terminal
Send a text message to a terminal in order to notify your customers about an important event or provide them with any other
information.
Use a terminal popup menu -> Message if you want to send a message to a single terminal.
Use main menu -> Tasks -> Message to send the message to all terminals in your cyber cafe.
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License Key (C D-Key) Management
C ut down your game licensing expenses using the C D-key management system. Purchase a quantity of licenses to cover
simultaneous gameplay vs. purchasing a license for every terminal where a game is installed.
TrueC afe license key management works the following way. All your game keys are stored in the TrueC afe license key pool. When a
customer starts a game on a terminal, TrueC afe dynamically reserves the next available key and send it to the terminal. When the
game is ended, TrueC afe delete the reservation and returns the key to the pool.

Maintain the license key list
Use the C D-key list (main menu -> Setup -> C D-Keys) to maintain your license key pool. Add, edit or delete your games and license
keys.

C onfigure game list
You provide your game license keys to a customer via game shortcuts on TrueC afe C lient programs panel. Use application profiles

(main menu -> Setup -> Terminals -> Application tab) in order to assign your game license keys to game shortcuts.
Read more about application profiles

Use license keys
In order to request and apply a game license key, customers have to start the game from TrueC afe C lient game panel:

If no available license key was found, a warning message is displayed to let a customer decide whether he is going to start the game
anyway:

Browse and delete key reservations
To browse the currenlty reserved license keys and failed key reservations use main menu -> View -> C D-Key reservations.
You can manually delete any reservation if you have decided that the key should not be longer reserved by a particular terminal.
When deleting a reservation, a corresponding game process can be terminated as well. Use options to turn on this feature.
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Quick Start
Installation
Run the installation program, select a directory where you want to install TrueC afe. It is recommended to use a local computer or a
domain administrator account to install the software.

Install the Server
Select the "Server, Administrator,.." item to install the core server components.
Select the "Traffic Meter" item if you want to calculate network traffic and include its cost to a user's bill. This option installs the traffic
calculation components including the WinPcap library (www.winpcap.org) that is used for network packets capturing.
Install Printer Watcher on a computer with a printer connected to automatically charge your customers for printing.

Use Windows Start Menu to start any application from TrueC afe program group:

Install the C lient
Select the "C lient.." item to install TrueC afe C lient software. Please note that TrueC afe C lient locks the terminal, so do not install this

Select the "C lient.." item to install TrueC afe C lient software. Please note that TrueC afe C lient locks the terminal, so do not install this
component on a computer that is critical to your business unless you are familiar with TrueC afe. You can use the closetruecafe
keyword as a password to close the demo version of TrueC afe C lient and unlock your computer.

Known issues. Windows XP
TrueCafe Client may conflict with your language settings. Please ensure that "Text Services and Input Languages -> Advanced ->
Extend support of advance text services to all programs" options is turned off:

Known issues. Windows Vista
We recommend running TrueC afe C lient with the administrative rights. Use the C lient.exe file properties, Run as Administrator
option to turn on this feature.

Upgrading to new version
You can install a new version of TrueC afe over the previous one, upgrading both server and client software.
TrueC afe database is upgraded automatically by Database Workshop utility when the installation is over. In case you get an error
message upgrading the database, please download and install the latest version of Microsoft Data Access components
If you upgrade from version 4.0 or earlier:
TrueC afe working files (your database, settings, backups, etc.) are now located in the application data folder instead the TrueC afe
installation folder as it were in the previous versions. So after you install a new version, please do the following:
1) Stop all TrueC afe services (C onrol Panel > Administrative tools > Services).
2) C opy (overwrite) backup and db folders and .ini files from your previous TrueC afe folder into:



Windows XP: C :\Documents and Settings\All Users\Application Data\TrueC afe\



Windows Vista: C :\ProgramData\TrueC afe\

3) Run TrueC afe Database Workshop and update your database (Windows Start Menu > TrueC afe > Database Workshop).
4) Start all TrueC afe services (C onrol Panel > Administrative tools > Services) again.

Uninstall TrueC afe
Use the "Uninstall" item from the TrueC afe program group to uninstall the software. If you installed TrueC afe TrafficMeter, you should
manually uninstall the WinPcap library then. WinPcap might be used by the other programs, so please uninstall it if you are sure that it
had not been installed before TrueC afe was. You can uninstall the WinPcap using the "Uninstall" item from the WinPcap Start Menu
program group.
TrueC afe database isn't deleted during the uninstallation. You have to delete it manually.
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Quick Start
Quick Start

TrueC afe Server Manager
Start TrueC afe Server Manager utility to make sure that the server is running. If it is stopped, start it by pressing the "Start" button.

TrueC afe Administrator
Start the TrueC afe application. Enter the user name and password on the "Logon" dialog:
Default administrator name/password are: Adm/adm

Read more about TrueC afe main administrative window

C onfigure terminals.
Read more about terminal management

C onfigure pricing.
Read more about pricing management

C onfigure the receipt that can be printed when stopping a session.
Read more about customizing a receipt

Start and stop customer sessions, add services such as printing, scanning, etc.
Read more about session management

TrueC afe C lient
If you use a demo version of TrueC afe, you can unlock a terminal using the empty user name and closetruecafe keyword as
a password.
C onfigure C lient on a terminal. Press the "Options" button to show or hide options pane. Set the server IP-address (IP-address of the
computer where TrueC afe Server is installed).

Read more about TrueC afe C lient
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Documentation
Info | Setup | Details | How to
Pricing

Sales Report

C ustomers

Traffic C alculation and URL Log

Tickets (Time C odes)

Bandwdith Management

Pre-Paid and Post-Paid Sessions

White List

Shifts

Point-of-Sale. Receipt

Point-of-Sale

Options

Inventory

Reports

Daily Report

C leanup
Database Workshop

Server Manager
C uteHotspot Server Manager indicates if C uteHotspot Server is running and provides start/stop/restart
functions.
C losing Server Manger does not stop C uteHotspot Server.
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TrueCafe. Quality Cyber Cafe Software.
General Info :: Get Started! :: Look C loser
Server Manager
Administrator
1. Workstations and Applications
2. Pricing
3. C ustomers
4. Tickets (Time C odes)
5. Sessions, Pre-paid, Timers
6. Point of Sale
7. Daily Report
8. Security
9. POS. Receipt
10. Traffic C alculation
11. Options
C lient
Reports
Printer Watcher
Language Editor
Database Workshop
Administrator
Security
Administrator role
TrueC afe provides a supervisor account called Adm. You can only use this account to change security settings.

User security settings
Use the "Access" tab of the "C lient" window to edit user security settings. You can change a password, specify whether the user can
logon to TrueC afe Administrator, allow or deny him/her to manage customers, jobs, services or workstations. C heck the "Reports"
option to allow the user to enter TrueC afe Reports.
If the "Applications" is checked then the user can configure workstation profiles and use "private" applications in TrueC afe C lient.
If the "TrueC afe C lient Management" is checked then the user can change TrueC afe C lient security level or close TrueC afe C lient
remotely.

Users with "Logon" option are colored in red in the customer list:

Lock
You can temporarily lock TrueC afe Administrator by pressing the "Lock" button. Double-click on TrueC afe icon in the system tray and
logon again to unlock the program:
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Terminals and Applications

C reate, edit and delete terminals

Name field value is up to you.
Computer name field is optional. Specify a computer name (UNC ) there if it differs from the Name field.
Assign a terminal static IP address or select the dynamic IP option.
Press the Receive MAC button after IP address is assigned and the terminal is on. TrueC afe uses the received MAC address to turn
on the terminal remotely.

State: enable / disable terminal for TrueC afe administration.
Profile: select a pre-configured profile to display application and game icons in TrueC afe C lient.
Print prevention: specify whether printing from this terminal is not allowed if a customer doesn't have enough money on his balance
left. Read more.
Price coeff: if you use terminal-dependent pricing, specify the pricing multiplier for this terminal. Price coeff = 1 by default, which
means the base pricing isn't changed for the terminal. Read more

Use Virtual tab to configure a thin-client terminal such as NC omputing or Windows Terminal Server one. Read more.

Arrange terminals
Move a terminal icon relatively to the real location of a terminal in your cyber cafe. Press the "Arrange terminals" button, drag and
drop the terminal icons and press the "Arrange terminals" again to save the positions.
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C lient

Lock a terminal
TrueC afe C lient locks a cyber cafe terminal.

C onfigure
Press the "Options" button to display the configuration pane, enter an IP-address of the computer where TrueC afe Server is installed.
Enter a background picture file name.
Select a dial-up connection if you want to connect/disconnect it when a customer logs on/logs off. This is useful in case you have a
remote terminal connected via GPRS, etc.
You can change options freely in the demo version TrueC afe. The options are protected with the unlocking code in the registered
version.

Display session info
A terminal is unlocked when a customer enters his name/password or a cyber cafe operator starts a customer session remotely. When
the terminal is unlocked, the session information window appears. A customer can top-up his balance using a ticket, change his
password, order a snack/drink or stop the session.

Select pricing while logging in

When a customer is logging in, the "Service package" list might appear. This depends on pricing configuration and happens if a
customer doesn't have a default pricing package and there are more than one "Public" pricing packages. Please read the Pricing topic
for more information.

Protect terminal
You can use the following features to secure your terminals:



Hide Windows Start button



Hide Taskbar



Hide Desktop items



Disable Task Manager



Disable Registry Editor



Hide Tray items



Hide Log Off



Hide Shut Down



Hide Run



Disable C ontrol Panel



Disable Windows hotkeys

Use TrueC afe options, Security tab to configure these settings.

Provide a set of applications
If you assign a terminal profile to a terminal, then a tab set with the applications is displayed. Double-click on any icon to start the
application:

Warn before session is finished
When a customer session has a critical amount of time/money left, a warning dialog is displayed and/or a warning sound file is played.
Use TrueC afe options to select your sound files to be played or specify whether the warning dialog must be displayed.

Printing confirmation
If the corresponding option is enabled, the confirmation dialog with pages/charge information is displayed when a customer prints a
document.

Order drinks/snacks
C ustomers can order goods, drinks, etc. from computers where they sit. They select an item in the list of services you configure in
pricing.
You can disable the "Order" button in TrueC afe options.

End a session (log off)
A customer can press the "Log Off" button to end his session and lock the terminal. The terminal is locked as well when a cyber cafe
operator remotely ends the customer session in TrueC afe Administrator.
Use TrueC afe options to utilize the next log off features:
1. C lose all running applications in order to prevent any private customer data from further browsing by the next user.
2. C lear Internet Explorer Temporary Internet Files and History.
3. Log off a session when a customer make Windows log off or shutdown.
4. Log off a session when a screensaver starts.
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Language Editor
TrueC afe interface supports unlimited number of languages. You can translate TrueC afe into your own language.
TrueC afe stores language settings in the .tcl files (eng.tcl for English, ger.tcl for German, etc.), that are located in the lang subfolder.
Those are text files that contain "key = value" pairs. You can easily edit the language files in any text editor.
Moremover, TrueC afe provides an integrated tool called Language Editor. It help you directly edit the language settings from the
running program. Press Ctrl-F11 in either TrueC afe Administrator, Report or C lient on any window to open the Language Editor. By
default, Language Editor displays the text messages from the last active window, but you can switch it to the "show everything" mode.
Edit the text and press "OK" to save the changes or "C ancel" to discard them.
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Power Management
TrueC afe power management features allow you to saver power, which actually means to save money, in your cyber cafe.

Shutdown idle or all terminals
Shutdown idle or all terminals in your cyber cafe by one click in main menu (Tasks -> Shutdown...):

Shutdown an idle terminal automatically
You can set a timer which turns off any idle terminal automatically after X minutes has gone. Use options to enable this feature.

Turn on a terminal remotely
If a terminal is off and you need to start a customer session on it, you can turn it on remotely:
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Printer Watcher
Printer Watcher automatically charges customers for printing on any printer in your cyber cafe. You can charge black-and-white and
colour printing using different rates.

Install
Install Printer Watcher on a computer with a printer connected:

Start Printer Watcher C onfig application from TrueC afe Start Menu program group, enter TrueC afe server IP address and start service
if it is stopped:

C onfigure
1. C heck whether the server receives print job information when you print on a printer that is being monitored by Printer Watcher
("Pricing" menu, "Print Jobs" button).
Print jobs are highlighted depending on the job state: not charged jobs background is painted in grey, cancelled jobs font - in red.

2. C heck whether the value in the "C omputer" column on the "Print Jobs" fits the ip address or name or "computer name" of any of
your terminals.

3. C onnect a printer to a pricing ("Pricing" menu):
C reate a new record, select a printer from the drop-down list and choose the colour-independent pricing or distinct pricings for both
monochrome and colour printing.

C harge
When a customer prints on a printer that is being monitored by Printer Watcher, he/she is automatically charged for printing:

Printing confirmation
When this option is enabled, TrueC afe C lient displayes the pages/charge information dialog when a customer prints a document. A
customer can then accept or decline the printing.

Print prevention
Stop printing on any printer in your cyber cafe when not enough money left on a customer's balance.
When a customer sends a document to a printer, TrueC afe calculates document pages/copies and how much we should charge him for
this document. Unless he has enough money left on his balance, the printing is stopped and a warning message is displayed on a
customer's terminal.
When a customer prints on a printer from a terminal, print prevention will be enabled if both the printer and the terminal have
"enable print prevention" option turned on.
You can select on which printers and which terminals you want to enable this feature on. For example, you may decide to avoid
monitoring of your receipt printer or any printing which is sent from administrative computer.
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Thin C lients. NC omputing and Windows Terminal Server Support
You can setup TrueC afe on a thin client multi-session platform such as NC omputing host (www.ncomputing.com) or Windows
Terminal Server. In this case a number of user sessions run on a host computer simultaneously. Each session is considered by
TrueC afe as a separate virtual terminal with TrueC afe C lient running. TrueC afe Server can be installed on either the same shared
computer or a detached one.
TrueC afe works well on NC omputing L100, L200 and X300.

Setup
1. Install TrueC afe Server on a server computer. It can be your multi-session host computer.
2. Add virtual terminals (use main menu -> Terminals):
Name: it's up to you
IP address: IP address of your multi-session host computer. It should be the same for all virtual terminals.
User name: user name which is used to logon to the terminal ("Terminal client login name" for NC omputing setup). You can see user
names in Task Manager -> "Process List" tab (Show processes from all users) -> "User name" column.

3. Install TrueC afe C lient on your host computer. Logon to the host computer under your administrative user account. Run TrueC afe
setup and install TrueC afe C lient. Restart the host computer. This will automatically start TrueC afe C lient for any terminal user session
then.
4. Login on your terminal (e.g. NC omputing box). Press the "Options" button on TrueC afe C lient login window. Enter a valid server IP
address (IP address of the computer where TrueC afe Server is running, it could be the same multi-session host computer where
TrueC afe C lients are installed).

5. Enter a TrueC afe user name and password to logon. You can use default adm/adm user name/password after the first installation.

NC omputing setup samples
1. All-in-one
NC omputing host is used for TrueC afe Server and C lients. Operator is working on the same host as customers do.
Use 127.0.0.1 or host IP (e.g. 192.168.1.1) for all IP options on the server and client sides.

Server side settings:

C lient side settings:

2. Detached operator/server computer
A separate operator/server computer is used with TrueC afe Server installed. TrueC afe C lient is installed on NC omputing host.

Server side settings:

C lient side settings:

Issues
Since TrueC afe C lient auto-starts for each user on your thin client host, you may need to disable this for some users such as
administrator. It can be accomplished by applying a special registry file which we send to our registered clients.
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Web Reports
Analyze your business data in your web browser. Get access to your cyber cafe activity information outside the cafe from the Internet.
Browse session, customer, service, terminal, etc. data for any period of time. View the diagrams which represent your business
growth. Print any report on your printer for further analisis.
TrueC afe Web Reports is based on ASP.NET platform which means it requires Microsoft .NET framework 1.1 or later installed. Web
Reports installs UltiDev C assini Web Server which hosts Web Reports application.
Download Microsoft .NET framework
Download TrueC afe Web Reports
Start Web Reports from TrueC afe program group:

Navigation
Each report contains the header navigation pane which allows you to switch back to the main menu page, log out from Web Reports or
select a period (today, yesterday, this week, last week, etc.) to display.

Report: Today
Displays today sessions, top-ups and services.

Report: Totals
Displays sessions, top-ups, promotional top-ups, services, etc. for a selected period. Income = top-up + post-paid.

Report: C ustomers
Displays customers with login, name, balance, etc.

Report: Tickets
Displays tickets with login, face value, balance, etc.

Report: Top-up
Displays customer balance top-ups.

Report: Sessions
Displays sessions: open / close dates, starting balance, minutes, amount, post-paid and whether a receipt was printed.

Report: Services
Displays services: units and amount.

Report: Terminals
Displays terminals: name, IP-address, minutes and amount.

Web Reports Access

An operator has to have the "Reports" option enabled in order to login to Web Reports:
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Wi-Fi Hotspot Support (Wireless Billing)
Introduction
Wireless billing allows you to charge the customers of your cafe, club, shop, hotel, etc. when they connect their laptops, PDAs or any
other mobile devices to your access point (Wi-Fi hotspot) and use the Internet to surf the web, read emails or chat via an instant
messenger.
When a customer first try to surf the web, TrueC afe detects the connection and redirects it to the TrueC afe Wi-Fi billing login page.
The customer uses his or her login information (printed e.g. on a ticket you sell, on a receipt of your cafe, etc.) to start a session.
When the balance is over, TrueC afe blocks any connection from the corresponding customer terminal.
In order to provide the wireless billing you have to install TrueC afe Server on your Internet gateway computer (Windows OS is only
supported). The gateway handles all network connections from your customer terminals.

We recommend the following approach... There are 2 network cards (NIC s) in your Internet gateway computer - NIC 1 and NIC 2.
NIC 1 is connected to the Internet (WAN) via xDSL/ADSL, C able, etc. NIC 2 is connected to your LAN: Wi-Fi access point, hub, switch,
etc.
Use Windows Internet C onnection Sharing feature in order to make a bridge between NIC 1 and NIC 2.

Setup
Setup Internet C onnection Sharing between the network cards on your Internet gateway (server) computer. Your WAN-connected
network card (NIC 1) has IP address usually provided by your Internet Service Provider. Your LAN-connected network card (NIC 2)
obtains some internal IP address, most often 192.168.0.1.
Read more about how to setup Internet C onnection Sharing
Your Wi-Fi access point uses DHC P to assign a dynamic IP to a customer's wireless laptop when it's connected. Access point gateway

IP setting is your NIC 2 IP address (192.168.0.1).
If you use a router in your LAN, it's gateway has to be your NIC 2 IP address as well (192.168.0.1).

You don't have to add your wireless terminals on the TrueCafe server side manually. TrueCafe automatically adds a
new terminal when a customer successfully logs in.
Use TrueC afe Wi-Fi options screen to select your NIC 2 adapter and enable the Wi-Fi billing feature (main menu > Tools > Wi-Fi...):

Run!
When a customer comes to your cafe, shop, hotel, etc. and connects to your Wi-Fi access point, it assigns a new dynamic IP address

to the customer's wireless laptop.
Then the customer tries to browse the web and since he or she hasn't been yet logged in, TrueC afe Server redirects him/her to the
login page.
The customer logs in using a ticket purchased or a member account and then is able to surf the web.
On the TrueC afe server side you see that a new Wi-Fi terminal is added.
In order to view the session info such as the balance or time left in a web browser, the customer types your gateway computer name
in the browser address bar (e.g. "gate" on the screenshot below).
The customer can log off from the session info page. You can also stop his session from the server side.
When the customer balance is over, TrueC afe automatically stops the customer session and blocks any connection from his wireless
terminal.

C ustomize
If you have some HTML experience, you can customize your Wi-Fi login and session info pages. Edit the login.html and info.html files
which are located in the TrueC afe\web folder.

C uteHotspot. Friendly Hotspot Software
C opyright © 2008 TrueC afe, Ltd.
All rights reserved.

Step-by-step Wireless Billing Setup
Windows 7 Wi-Fi billing setup

Introduction
This article demonstrates how to setup a very simple Wi-Fi billing approach. You need the following
hardware:
1. A server computer which is connected to the Internet (e.g. via ADSL modem).
2. An extra LAN (Ethernet) card.
3. Wireless router (Linksys WRT54G, D-Link DIR-300, etc.)
The idea is to make your server computer your Internet gateway computer, which means the computer
with C uteHotspot Server installed is located between your ADSL router and Wi-Fi router:

1. Plug in extra Ethernet card
Plug in your extra Ethernet card into your server PC I slot and let Windows detects the card and install
the corresponding network card driver.
In this example Local Area Connection 1 (NIC 1) is a primary card connected to the ADSL modem
and Local Area Connection 2 (NIC 2) is an extra network card:

2. Enable Internet Connection Sharing
Open your NIC1 properties and enable Internet C onnection Sharing. If you have more than 2 cards
enabled, you have to select your NIC 2 in the list:

Open your NIC2 properties and change default IP address and subnet mask to
IP address = 192.168.0.2
Subnet mask = 255.255.0.0

2.A. What if you don't like Internet
Connection Sharing
If you think that Internet C onnection Sharing is not OK for you, you could try some other alternative
Windows routing software. We recommend using NAT32 since many our clients use it and it proves to
work well with C uteHotspot.

3. Setup Wi-Fi router
C onnect your NIC2 with a cable to your router LAN port (not Internet port):

Set the router IP address = 192.168.0.3. Switch the router into Access Point mode. Disable router
DHC P.
Read more on how to setup your router model:
Linksys router setup (WRT54GL)
D-Link router setup (DIR-300)

4. Connect Wi-Fi laptop
C onnect your Wi-Fi laptop to your wireless network and make sure that you can surf the web.

5. Setup CuteHotspot Server
Install C uteHotspot on your server computer.
Open C uteHotspot main menu > Tools > Internet... , select your NIC2 and enable the Wi-Fi billing
option:

6. Login Wi-Fi laptop
Try opening any website from your Wi-Fi laptop and get TrueC afe login page. Type your customer/ticket
login/password to start a session and continue browsing the web. Try login/password = test/test by
default.

Setup Linksys DIR-300 Wi-Fi Router
Login to your router control panel. Open Setup > LAN Setup , change your router IP address if needed
and disable DHC P server:

The Internet options Setup > Internet Setup remain default:

Setup Linksys WRT54GL Wi-Fi Router
Login to your router control panel. Open Setup > Basic Setup , change your router IP address if
needed and disable DHC P server:

Open Setup > Advanced routing and set Operating mode = Gateway:

Step-by-step Wireless Billing Setup
on Windows 7
Introduction
This article demonstrates how to setup a very simple Wi-Fi billing approach. You need the following
hardware:
1. A server computer which is connected to the Internet (e.g. via ADSL modem).
2. An extra LAN (Ethernet) card.
3. Wireless router (Linksys WRT54G, D-Link DIR-300, etc.)
The idea is to make your server computer your Internet gateway computer, which means the computer
with C uteHotspot Server installed is located between your ADSL router and Wi-Fi router:

1. Plug in extra Ethernet card
Plug in your extra Ethernet card into your server PC I slot and let Windows detects the card and install
the corresponding network card driver.
In this example Local Area Connection 1 (NIC 1) is a primary card connected to the ADSL modem
and Local Area Connection 2 (NIC 2) is an extra network card:
Windows C ontrol Panel > Network and Internet > Network and Sharing C enter > C hange adapter
settings (on the left)

2. Enable Internet Connection Sharing
Open your NIC1 properties and enable Internet C onnection Sharing.

Windows setup the following NIC2 properties:
IP address = 192.168.137.1
Subnet mask = 255.255.255.0
You should not change these values because Internet C onnection Sharing may stop working.

2.A. What if you don't like Internet
Connection Sharing
If you think that Internet C onnection Sharing is not OK for you, you could try some other alternative
Windows routing software. We recommend using NAT32 since many our clients use it and it proves to
work well with C uteHotspot.

3. Setup Wi-Fi router
C onnect your NIC2 with a cable to your router LAN port (not Internet port):

Set the router IP address = 192.168.0.3. Switch the router into Access Point mode. Disable router
DHC P.
Read more on how to setup your router model:
Linksys router setup (WRT54GL)
D-Link router setup (DIR-300)

4. Connect Wi-Fi laptop
C onnect your Wi-Fi laptop to your wireless network and make sure that you can surf the web.

5. Setup CuteHotspot Server
Install C uteHotspot on your server computer.
Open C uteHotspot main menu > Tools > Internet... , select your NIC2 and enable the Wi-Fi billing
option:

6. Login Wi-Fi laptop
Try opening any website from your Wi-Fi laptop and get TrueC afe login page. Type your customer/ticket
login/password to start a session and continue browsing the web. Try login/password = test/test by
default.

